First run after installation - permissions problem

More
29 Aug 2013 17:48 - 29 Aug 2013 17:54 #1415 by Tjauw
Hi,
I am a Drupal user but decided to try Joomla, purely based on your impressive demo. I installed Joomla 2.5.14 successfully on my Apache server and subsequently your component and search module. I installed the sample data, created a user that belongs to the admin group, checked permissions in the backend of Domus, added Domus to the Menu and had a look at my first primitive Joomla site using it's default template. I tried the search options and got results without pictures. I noticed some php errors:


1. Trying to get property of non-object in C:\....\components\com_domus\router.php on line 53
2. Trying to get property of non-object in C:\....\inmonatural\components\com_domus\router.php on line 53
3. Trying to get property of non-object in C\....\modules\mod_domussearch\tmpl\default.php on line 20
4. Undefined variable: image_dir in C:\....\components\com_domus\helpers\html.php on line 207
Prop. ID
5. Undefined variable: image_dir in C:\....\components\com_domus\helpers\html.php on line 207
Price
6. Undefined index: view in C:\....\components\com_domus\router.php on line 59
7. Trying to get property of non-object in C:\....\\components\com_domus\router.php on line 53

Clicking on the Prop.ID link (notice 4) or Price link (notice 5) brings me to the Domus control panel leaving notices 3 and 6 visible.
Clicking on any link in the search results gives me a 403-permission problem. The same happens in the control panel.

I have been trying different users belonging to different groups. Nothing changes.

What am I doing wrong?

Thank you for your help.
Last edit: 29 Aug 2013 17:54 by Tjauw. Reason: readability

Please Log in to join the conversation.

More
09 Sep 2013 15:47 #1442 by Tjauw
Well, I tried but unfortunately nobody seems to be able to help me while a number of visitors seems to be looking for an answer on the same question.......

Looking for a Drupal solution again now.

Please Log in to join the conversation.

More
09 Sep 2013 15:55 #1443 by admin
Sorry, I just missed this post notification :(

First of all you should lower your error notification. We're polishing up the code, but some notices are still visible.
Did you tried using a super admin?

Please Log in to join the conversation.

More
09 Sep 2013 16:01 #1444 by Tjauw
I fail to see how hiding the mentioned errors could solve my problem. Yes, I tried all levels of users.

Please Log in to join the conversation.

More
09 Sep 2013 16:14 #1445 by admin
You won't solve any error, but it will make your life easier.
Most likely there is a problem while setting up menu.
Did you nested them, or are just on the same level?

Please Log in to join the conversation.

More
09 Sep 2013 16:24 #1446 by Tjauw
Thank you for your help.

I already cleaned up my testing environment. As I mentioned before I
am new to Joomla and found a quick way to include Domus in the main menu
where it correctly appeared. I suppose that this will be on the same level,
not nested.

Forgetting about the visible php errors, I fear that the real
problem is not in the menu but in the permissions as described in my
original mail.

If you think we can easily solve this problem I will be happy to set up my testing environment again.

Please Log in to join the conversation.

Time to create page: 0.196 seconds