[SOLVED] Activities time is always "plus 2 hours"

More
27 Aug 2012 11:01 - 15 Nov 2012 12:24 #70 by admin

GammX1 wrote: 1) Each time and 'Activity' is saved the time frame finally saved is always 2 hours later of the real time but the worst is that if modified and saved again additional 2 hours are added... This could never be acceptable if the target is to keep a 'real time' report that could be presented to the final customer at any time...
>> Is there a way to set that to accept the date & time introduced manually (regardless the time that your program thinks is the real one as per server settings or any other consideration may have)?


In the activity view, start and stop time are handled using the Joomla calendar function.
You can manually edit the time, as default TrackTime takes the current server time.
Sadly it could be very different from your local one (time zone and daylight save settings). However, the extension only "suggest" it: if you change the value, TrackTime will save that value.

If you use the timer, things are different.
Start and stop time are calculated client-side (in your browser using javascript), so you'll have the correct time.
Can you tell me the steps to reproduce the error you're reporting?

2) You have been very clever considering to give 'data encription' inside '#__tracktime_projects to the SU, Psswrd, DB Host, DB User, DB Psswrd, DB Name, FTP URL, FTP User, FTP Psswrd fields.... The question is why not to protect the: Domain Control Panel, Domain CP User, Domain CP Psswrd fields, too?


Whops! :whistle:
We have fixed it, we're going to release a new version for this issue.

Finally, to have the option to generate a 'Project Status report' under a nice an easy presentation manner (html or PDF) that could allow to be send by email to the final customer at any time, should be a very welcome feature, too


We have just finished working on this feature: you can select a set of activities and email them to the customer.
You can find it in the Professional version (since templates are required and they're inside the pro version) as soon as we publish the new release.
By the way, do you have any particular need?
I mean, in addition of email reports, do you need any different report?
Maybe we can manage to add them inside the new version.
Last edit: 15 Nov 2012 12:24 by admin.

Please Log in or Create an account to join the conversation.

More
27 Aug 2012 17:46 #72 by GammX1

Can you tell me the steps to reproduce the error you're reporting?

>> Just create a 'New Activity", set the project and its correcponding 'Hour Stack' from where to deduce the time consumed, add description, click on 'Start' at the timer': You will see the correct date and time is displayed
After 15 minutes stop the timer and 'save & close' the activity ... Will be saved but with time 2 hours late
>> Open again the recently created 'activity' change something at the description field and 'save & close' it ... You will see that 2 additional hours have been added to the lastest ones (being now 4 hours later than the real time)... That's really an unaceptable bug if we will need later to create acurate customer reports.

Please Log in or Create an account to join the conversation.

More
27 Aug 2012 18:17 #73 by GammX1

We have just finished working on this feature: you can select a set of activities and email them to the customer.
You can find it in the Professional version (since templates are required and they're inside the pro version) as soon as we publish the new release.
By the way, do you have any particular need?
I mean, in addition of email reports, do you need any different report?
Maybe we can manage to add them inside the new version.


>> There are three default reports that I foreseen could be needed by default:
1) the first needed report is always the 'Project credentials Data' that must be sent to the final customer right after the server is set and consigured and the website is going to production, this report must be printable and can be saved as pdf to be emailed.
2) The second one is a default report of a single project with detail of all of its assigned activities and time consumed. this report must be printable and can be saved as pdf.
3) The third one should be a 'CUSTOMER' one with all of its assigned 'projects' with detailt of their 'activities' and his whole 'Hours Stack' balance. this report must be printable and can be saved as pdf.

Hope this helps,
GammX1

Please Log in or Create an account to join the conversation.

More
27 Aug 2012 19:31 #74 by admin
Thanks for you suggestions, we'll try to develop them in the next release
The following user(s) said Thank You: GammX1

Please Log in or Create an account to join the conversation.

More
27 Aug 2012 19:47 #75 by GammX1
Thanks for your attention and quick answers...
I'm open to go for the Pro version right after your next release be released & succesfully tested, even ready to add a positive review at JED after succesfull test (I'm not giving my review at JED now because only one review by user to a single extension is allowed... Then better to wait till a '5-Stars' review could be set for TrackTime ;-)
Waiting your finall confirmation about next release,
Rgrds,
GammX1

Please Log in or Create an account to join the conversation.

More
27 Aug 2012 19:51 #76 by admin

GammX1 wrote:

Can you tell me the steps to reproduce the error you're reporting?

>> Just create a 'New Activity", set the project and its correcponding 'Hour Stack' from where to deduce the time consumed, add description, click on 'Start' at the timer': You will see the correct date and time is displayed
After 15 minutes stop the timer and 'save & close' the activity ... Will be saved but with time 2 hours late
>> Open again the recently created 'activity' change something at the description field and 'save & close' it ... You will see that 2 additional hours have been added to the lastest ones (being now 4 hours later than the real time)... That's really an unaceptable bug if we will need later to create acurate customer reports.


mhm.. sorry but everything is working fine for me...
this is what i did:
  1. New activity, fill every info. Please note that the "start/stop" field are taken from the server, so they could be wrong (ie 17:33 instead of 19:33)
  2. Start the timer
  3. Wait 10 minutes
  4. Stop the timer
  5. The timer will update the start/stop fields. But now they are the corrects ones, since they're calculated client-side: start= 19:33 stop=19:43
  6. Save everything

Even if i edit the record, dates are correct.
It's very strange, since you're the only one that report this bug. Are you sure you're not deleting the start/stop time?
If you do the same steps above, is everything ok?

Please Log in or Create an account to join the conversation.

Time to create page: 0.287 seconds